TableTools support Japanese or Chinese?

TableTools support Japanese or Chinese?

shenshen Posts: 3Questions: 0Answers: 0
edited January 2010 in Plug-ins
Does TableTools support Japanese or Chinese? After i saved as CSV or Excel, the file can not be read - the Japanese or Chinese character doesn't show well. How can i handle it?
By the way, thanks to the GOOOD work!!!

Replies

  • allanallan Posts: 55,076Questions: 1Answers: 8,645 Site admin
    Hi shen,

    This is a known issue with TableTools, and one I'm actively looking into at the moment. The problem is that Excel isn't importing the file as a UTF8 file - so I need to try and figure out how to make it do that... Keep an eye out on the RSS feed for a new release of TableTools.

    Regards,
    Allan
  • shenshen Posts: 3Questions: 0Answers: 0
    Thank you Allan for your rapid reply~~~ :-)
  • allanallan Posts: 55,076Questions: 1Answers: 8,645 Site admin
    Hi shen and all others interested in UTF-8 support,

    I've managed to put together a proof of concept that works quite well with UTF-8 support, but implementing it in production ready code (or anything more than proof of concept) it proving to be very difficult in Flash. I've logged two bugs with Adobe about their UTF support in Flash player, and hope they are able to respond to them quickly. In the mean time, I think I'm going to have to find a way around the issue, and not use the built in Flash character conversion functions.

    Regards,
    Allan
  • shenshen Posts: 3Questions: 0Answers: 0
    Nice Allan! Thank you very much! I am not good at this, so i hope you can solve it. :-)
  • act28act28 Posts: 2Questions: 0Answers: 0
    Not sure if this is a related issue, but when the browser language is set to Japanese, the DataTables plugin does not render the table at all. By that I mean, the table and table data is displayed as normal, but there is no pagination, no search, and no column sort.

    However, the exact same code works fine if the browser language is set to English.
  • allanallan Posts: 55,076Questions: 1Answers: 8,645 Site admin
    Do you get any Javascript errors when the browser language is set to Japanese?

    Allan
  • act28act28 Posts: 2Questions: 0Answers: 0
    Sorry, my bad... I didn't include the javascript in the head for the JA templates. It's working now. :S
This discussion has been closed.