Grey boxes for TableTools when disabled

Grey boxes for TableTools when disabled

amitywebamityweb Posts: 5Questions: 3Answers: 0
edited March 2014 in TableTools
I've installed TableTools and all buttons except the last one for Print are these grey boxes. If I hover over them an X appears, no text. It does not look very good. Is this intentional or are there issues with styling? I am using Chrome 33.0.1750.152

If I disable position: relative for a.DTTT_button, then all of them work except the first one, which still stays grey. Cant see how to fix that one.

Thanks

Replies

  • amitywebamityweb Posts: 5Questions: 3Answers: 0
    Ah, I found the issue. I didnt realise this uses Flash. When I found out I remembered I have disabled plugins to run automatically in my browser because I am sick of going to websites that have videos play automatically! Usually there is a message saying to click to play the plugin. As these boxes are really small, you cant see that message, its just a grey box, and a cross appears when you hover over.

    Might be worth showing a message, if possible, if flash is not supported or disabled.

    All working now though!
  • allanallan Posts: 54,703Questions: 1Answers: 8,556 Site admin
    Interesting. Yeah - the Flash requirement is a massive pita. I would seriously love to drop it. I wrote a blog post about it recently: http://next.datatables.net/blog/2014-01-31 . Basically we can't yet.

    But you are right, I need to show a better message. I'll look into that.

    Allan
This discussion has been closed.