Using Datatables jQuery in IE 8 i see issue,Chrome is working fine , in IE8 table shows null

Using Datatables jQuery in IE 8 i see issue,Chrome is working fine , in IE8 table shows null

DjustinDjustin Posts: 3Questions: 0Answers: 0
edited April 2014 in DataTables 1.9
var data = [{"lastUpDate":"21-APR-14","countryAccess":"CHL,PAN","name":"A, Suresh Babu","emplid":"024312","createdUser":"013241","accessType":"Y"},{"lastUpDate":"22-APR-14","countryAccess":"MYS,NZL,PHL","name":"Agarwal, Deepali","emplid":"033129","createdUser":"013241","accessType":"Y"},{"lastUpDate":"23-APR-14","countryAccess":"MYS","name":"Aoki, Susan","emplid":"026243","createdUser":"013241","accessType":"Y"},{"lastUpDate":"23-APR-14","countryAccess":"MYS","name":"B A, Sumathi","emplid":"011856","createdUser":"013241","accessType":"Y"},{"lastUpDate":"24-APR-14","countryAccess":"ITA,KAZ","name":"Bhat, Ram","emplid":"026072","createdUser":"013241","accessType":"Y"},{"lastUpDate":"22-APR-14","countryAccess":"MYS,CANPE","name":"Cassell, Loellyn","emplid":"002209","createdUser":"013241","accessType":"Y"},{"lastUpDate":"22-APR-14","countryAccess":"POL,ROI","name":"Hamdani, Syed","emplid":"019283","createdUser":"013241","accessType":"Y"},{"lastUpDate":"14-APR-14","countryAccess":"MYS,PHL,CANBC,ITA","name":"Johnson, Barry","emplid":"010633","createdUser":"025695","accessType":"Y"},{"lastUpDate":"22-APR-14","countryAccess":"MYS","name":"Kumar, Suresh","emplid":"011482","createdUser":"013241","accessType":"Y"},{"lastUpDate":"10-APR-14","countryAccess":"MYS,BRA","name":"Kurian, George","emplid":"025695","createdUser":"003356","accessType":"Y"},{"lastUpDate":"24-APR-14","countryAccess":"CANPE","name":"Makhija, Ramesh","emplid":"009660","createdUser":"013241","accessType":"Y"}]
// alert("data $$ "+JSON.stringify(data));

$(document).ready(function() {
$('#divCountrySupMP').hide();
$('#buttonsDiv').hide();
$('#lastName').val("");
$('#firstName').val("");
$('#hrID').val("");

$('#dvLoading').hide();

$('#divCountriesCheck').hide();
$('#divCountriesCheck div').empty();

$('#exCountrySetup').dataTable({
"aaData" : data,
"aoColumns" : [ { "mData" : "emplid","sClass": "myfont"
},{
"mData" : "name","sClass": "myfont"
},{
"mData" : "countryAccess","sClass": "myfont"
}, {
"mData" : "accessType","sClass": "myfont"
}, {
"mData" : "createdUser","sClass": "myfont"
}, {
"mData" : "lastUpDate","sClass": "myfont"
},{
"mData" : null,
"sClass" : "center",
"bSortable": false,
"sDefaultContent" : "" }
]
});
});


I tried removing name and country access data and checked for if comma is creating issue. but no luck.pleas help i am stuck on this issue.

Replies

  • allanallan Posts: 54,921Questions: 1Answers: 8,611 Site admin
    Can you link to a test case please.

    Allan
  • DjustinDjustin Posts: 3Questions: 0Answers: 0
    Hi Allan,

    I tried to create case but could not include the datatable.js in it. hence i tried myself to resolve it.
    Thanks for your immediate reply.
    Issue : data jsonarray [list] i.e. could not parse it with mdata in datatable.
    resolution:1. tried changing the data in to list that worked for mdata.
    2. as i dont want to change my old data with aocolumns mdataprop worked .
  • allanallan Posts: 54,921Questions: 1Answers: 8,611 Site admin
    Your code from above appears to run just fine if I drop it into a test case: http://live.datatables.net/paxuset/1/edit .

    I'm not sure I see what the issue is?

    Allan
  • DjustinDjustin Posts: 3Questions: 0Answers: 0
    Hi Allan,


    Thanks for dropping in test case , i was able to run in chorme. but when i copy the same url in ie 8 i see script error . check it out in ie 8 document mode : IE 8
This discussion has been closed.