TableTools not working in Firefox 29, IE11, Opera

TableTools not working in Firefox 29, IE11, Opera

cwillardcwillard Posts: 2Questions: 1Answers: 0

Having the issue on my own site, but I've noticed the same behavior on DataTables own site here: http://www.datatables.net/release-datatables/extensions/TableTools/examples/collection.html

  • On Chrome 34.0.x, all Tabletools buttons work as expected.
  • On Firefox 29.0.1 (safe mode and regular mode), Copy button, and CSV/Excel/PDF buttons under the Save button are all grayed out and not clickable
  • On IE 11 buttons display properly, but CSV/Excel/PDF buttons do nothing when clicked
  • On Opera 21.0, Copy button and CSV/Excel/PDF are covered by gray boxes that are closable, but when closed, buttons do nothing.

Is this a known bug? From what I can gather, there's something amiss with Flash.

Thanks!

Answers

  • boschertjd18boschertjd18 Posts: 1Questions: 0Answers: 0

    Agreed, I'm seeing the same issues

  • mRendermRender Posts: 151Questions: 26Answers: 13

    Chrome is fine for me, FF the buttons save as "all types" and not the specific type of the button clicked. Thought I'd add my findings.

  • allanallan Posts: 54,702Questions: 1Answers: 8,556 Site admin

    Sounds very much like a Flash issue. Do you have Flash installed and enabled?

    Its very frustrating that the browsers are actively trying to kill Flash, when HTML5 still can't do the things TableTools needs! I'm going to have to put in a workaround I think.

    Allan

  • cwillardcwillard Posts: 2Questions: 1Answers: 0

    Fixed this issue - I reinstalled Flash and problems went away. Personally I'd LOVE to see a non-Flash implementation of the TableTools functionality.

  • aliaezataliaezat Posts: 1Questions: 0Answers: 0

    I am having the same issue. CSV, Excel and PDF are clickable but are not working in firefox. I am trying the online demo on your site and it is not working. I also re-installed flash and still not working.

    Is there an estimate when this bug can be fixed?

  • tangerinetangerine Posts: 3,112Questions: 25Answers: 364

    I am trying the online demo on your site and it is not working.

    It's working for me. Firefox 32.0.3

  • allanallan Posts: 54,702Questions: 1Answers: 8,556 Site admin

    Seems to work for me as well. Try Chrome perhaps and see if it works there?

    We would need a way to be able to reproduce the issue to be able to help resolve it.

    Regarding a non-Flash version, I wrote this blog post about it a little while back.

    Allan

This discussion has been closed.