Cookies stopping IIS7

Cookies stopping IIS7

dennismcdennismc Posts: 6Questions: 0Answers: 0
edited July 2010 in Bug reports
I have been having a problem for a few weeks while developing a complex Classic ASP site.

I have traced the problem to be linked to datatables.

When I start using the site, and then do not load any pages for lets say 5 minutes as I may be editing an ASP page, as soon as I go back to the site in my browser (Firefox and IE) and click a link or try and refresh the page does not get displayed and I just get a rotating image on the tab to show the site is loading, it never loads. If I clear cookies and refresh it takes me to the login page (this is correct) then it will work again until it is left idle.

I have been pulling my hair out, but have found that if I do not use your code the problem does not arise as no cookies are created, OR if I use your code but have

"bStateSave": false,

Then again the cookies are not created and the problem does not occur, I can leave the site for 15 minutes, then click a link and the site continues to work.

I would like to be able to allow the bStateSave to work.

I wonder if anyone has any ideas how to overcome this problem.

Thanks, Dennis

Replies

  • allanallan Posts: 57,236Questions: 1Answers: 9,113 Site admin
    Interesting - I've not come across this problem before. Can you perhaps post an example page showing it in action? It would be interesting to see if the server is returning an HTTP status code, or if it's the Javascript which is killing it. Also what version are you using? The 1.7 beta has a significant change for cookie handling in it.

    Regards,
    Allan
  • dennismcdennismc Posts: 6Questions: 0Answers: 0
    Hello Allan,

    The site is part of a private intranet, however I could setup a copy and provide you a password to logon and see what’s happening, is it possible to send you a private message with the URL and logon details?

    I should mention that this does not seem to be a problem when using IIS6, but is a problem when using IIS7, I have un-installed and re-installed IIS7 and looked for answers on the internet as I thought the problem was IIS7 and not datatables, however it seems to be the interaction between the two, and only when datatables is storing the cookies?

    I am using version 1.6.2, is the 1.7 beta completely backwards compatible with 1.6.2 or would I have to alter anything ?

    Regards

    Dennis
  • allanallan Posts: 57,236Questions: 1Answers: 9,113 Site admin
    Hi Dennis,

    The 1.7 betas aren't 100% backwards compatible, but I'd say around 95%! You'll run into problems if you are manipulating aoData at all (i.e. fnDeleteRow), or custom regular expression filtering but for almost everything else it should be good to go. There is a new beta due sometime soon which will address a couple of minor issues which have been noted as well (mainly around the new scrolling feature).

    My guess is that the cookies are bigger than 4K, and IIS7 is getting rather upset about it. It might be that you would need to use Wireshark to check if this is the case or not. DataTables 1.7 includes a new method to stop this from happening:

    http://datatables.net/new/1.7
    http://datatables.net/upgrade/1.7

    Also you can contact me directly using http://datatables.net/contact

    Regards,
    Allan
  • dennismcdennismc Posts: 6Questions: 0Answers: 0
    Hello Allan,

    I have just tried the 1.7 beta and the same thing happens, so it does not seem like the 4K limit.

    I am going to try and access it from outside my network this evening to see if that has any effect.

    Dennis
This discussion has been closed.