Javascript Problem In TableTools

Javascript Problem In TableTools

dobulet302dobulet302 Posts: 38Questions: 0Answers: 0
edited August 2010 in TableTools
I am getting the following error in the ZeroClipboard.js file

this.movie.clearText is not a function (Line 279)

No idea what is causing this, my table renders however the only thing that does is the option to sort.

[code]

$(document).ready(function() {

$('#table').dataTable( {
"sDom": 'T<"clear">lfrtip',
"aaSorting": [[ 0, "desc" ]],
"bJQueryUI": true,
"sPaginationType": "full_numbers",

} );

} );

[/code]

Replies

  • dobulet302dobulet302 Posts: 38Questions: 0Answers: 0
    Ok I was able to get the TableTools to dispplay, however here are the problems I have.

    I get the following error:

    this.movie.clearText is not a function on Line 279.

    The Print button works, however none of the export to csv/excel buttons work and when you click copy to clipboard, it will alert you how many rows were copied however the copying never happens.
  • dobulet302dobulet302 Posts: 38Questions: 0Answers: 0
    Well sorta solved my own forum question, I was able to fix it. Awesome stuff!
  • kkudikkudi Posts: 77Questions: 0Answers: 0
    dobulet302, I have the same javascript error, could you please tell me what you went about solving it?
    Thanks
  • dobulet302dobulet302 Posts: 38Questions: 0Answers: 0
    Made my script like the following.

    [code]

    $(document).ready(function() {
    TableToolsInit.sSwfPath="swf/ZeroClipboard.swf";

    $('#table').dataTable( {

    "bPaginate": false,
    "bJQueryUI": true,
    "sDom": '<"H"lTfr>t<"F"ip>'
    } );


    } );

    [/code]
  • mgmg Posts: 47Questions: 0Answers: 0
    I'm getting the "this.movie.clearText is not a function" error as well in Firefox.
  • boudgaboudga Posts: 11Questions: 0Answers: 0
    go into ZeroClipboard.js and make line 279 look like this:

    [code]//this.movie.clearText();[/code]

    That fixed it for me! Yea!!!
  • allanallan Posts: 54,914Questions: 1Answers: 8,608 Site admin
    Make sure you are using the version of ZipClipboard that each TableTools release comes with as they are not identical between releases. Note that this is an old thread (3 months or so) and refers to TableTools 1.x initialisation, which has changed for TableTools 2.x.

    Allan
  • boudgaboudga Posts: 11Questions: 0Answers: 0
    our application still uses version 1.1.1
  • allanallan Posts: 54,914Questions: 1Answers: 8,608 Site admin
    Okay - thanks for the clarification. Sounds like a little bug in 1.1.1 then - thanks for flagging it up.

    Allan
This discussion has been closed.