When using "keys": true and "paging": false, will cause paging to turn on

When using "keys": true and "paging": false, will cause paging to turn on

tstonehbststonehbs Posts: 5Questions: 1Answers: 0

Using keys: true with paging: false doesn't work. Paging gets turned back on when keys is turned on.

See the example link below for an example, click toward the bottom of the table and you'll notice that paging gets turned on, which is not the desired outcome.

Example:
http://live.datatables.net/noximaju/1/

$(document).ready( function () {
  var table = $('#example').DataTable( {
    "keys": true,
    "paging": false  
    });
} );

This question has an accepted answers - jump to answer

Answers

  • jLinuxjLinux Posts: 981Questions: 73Answers: 75

    Are we maybe seeing completely different results? I didnt change the JS in your JSBin at all, and it seems to work fine for me: http://d.pr/i/6Ayk

  • tstonehbststonehbs Posts: 5Questions: 1Answers: 0
    edited October 2015

    Yes we are seeing completely different results. Your table only has 3 item, mine had 57. Not sure why you only see 3. You'll need more than 10 rows, as that is the default page size to see the problem.

    The body of the HTML is too long to post in this reply.

  • allanallan Posts: 54,880Questions: 1Answers: 8,601 Site admin

    Thanks for posting this - it most certainly looks like a bug. let me look into it when I get in tomorrow and I'll get back to you.

    Allan

  • jLinuxjLinux Posts: 981Questions: 73Answers: 75
    edited October 2015

    I said i didnt change the JS, i removed most of the rows to make this easier to diagnose, and so i could see the paging buttons..

    But even with more than 10 rows, it seemed fine for me, weird...

  • tstonehbststonehbs Posts: 5Questions: 1Answers: 0
    edited October 2015

    You don't need to remove any rows to see the problem, I have that many rows there so you could easily see the problem. Using all 57 rows and viewing the table in the output window will display "Showing 1 to 57 of 57 entries" at the bottom of the table. Now if you select row 11 it will not show rows 1 through 10, it will start with row 11 and will display "Showing 11 to 57 of 57 entries" at the bottom of the table. Paging was set to false and the table should always display "Showing 1 to 57 of 57 entries".

    I think you are just looking for "paging buttons", and I don't have them turned on. The data that is being displayed is acting like paging is turned on, maybe partially, but still turned on and hiding data from the end user.

    I think Allan saw the problem and I await his answer tomorrow.

  • allanallan Posts: 54,880Questions: 1Answers: 8,601 Site admin
    edited October 2015 Answer ✓

    Two errors here I'm sorry to report:

    1. DataTables was reporting a page length of 10 when paging was disabled (should be -1) - fix.
    2. KeyTable wasn't handling the -1 page length correctly - fix

    The nightly versions of both are now up to date and the example runs correctly now.

    Thanks for letting me know about this!

    Allan

  • tstonehbststonehbs Posts: 5Questions: 1Answers: 0

    Thanks Allan for the prompt fix!

    On # 2 above, that fixes the error "Uncaught RangeError: Maximum call stack size exceeded" when I tried to manually set "pageLength" to -1.

    Also thanks jLinux for making me fully explain the problem.

  • allanallan Posts: 54,880Questions: 1Answers: 8,601 Site admin

    I haven't been able to recreate that - http://live.datatables.net/noximaju/5/edit .

    Can you give me a link to a test case please.

    Allan

This discussion has been closed.