Pagination buttons are not viewing/aligned correctly

Pagination buttons are not viewing/aligned correctly

viji_laksviji_laks Posts: 5Questions: 0Answers: 0
edited May 2011 in DataTables 1.8
Hi Allan,

Thank you for the wonderful plugin.

But I have an issue with displaying my nav. buttons on top right of my table. They appear one by one with an unidentifiable "cursor" like image at the top of it. So, pretty much 4 lines are occupied to show 2 buttons. I'm sure I'm not using my css correctly..I'm a newbie to JS and to JQuery/datatables. Kindly help me identify the issue and solve it.

(Not sure how I could attach the JPEG of my page image to show the problem)
Thanks

Replies

  • viji_laksviji_laks Posts: 5Questions: 0Answers: 0
    Also, let me give the code that I use to draw my table.
    css:
    div.rightcolumn {
    float:right;
    width:10%;
    height:auto;
    }

    $('#listTableId').dataTable( {
    "bJQueryUI": true,
    "sPaginationType": "two_button",
    "bLengthChange": false,
    "bProcessing": true,
    "bInfo": true,
    "bFilter": false,
    "aaSorting": [[1, "desc"]],
    "aoColumns": [{ "sType": "html" }, { "sType": "liveStart_date" }, { "sType": "archEnd_date" }, { "sType": "html" }],
    "sDom": '"<"rightcolumn"p><"top"i>rt<"bottom"><"clear">'
    });
  • allanallan Posts: 54,712Questions: 1Answers: 8,558 Site admin
    Does this occur only in 1.8 (just wondering why it's in the 1.8 category). If you use 1.7.6 does it work okay? Remember that 1.8 is in beta at the moment.

    If you can link to a page showing this problem that would be good.


    Allan
  • viji_laksviji_laks Posts: 5Questions: 0Answers: 0
    Thanks for that quick response...

    I'm using 1.8 version from the start, so I had put that in that category.. I did not try in 1.7...

    I'm running this in my local weblogic and this page is the outcome of an ajax call which needs some parameters for the call, not sure how I could give that link, even if it is accessible from outside...
  • viji_laksviji_laks Posts: 5Questions: 0Answers: 0
    I have a jpeg file showing the buttons image but is there any email id that I could send to?
  • viji_laksviji_laks Posts: 5Questions: 0Answers: 0
    Allan, I resolved it myself, the css was missing something...I did get the demo_table_jui.css version that worked fine.

    Thank you for such a quick response and sorry for having wasted your time (a typical newbie problem).
This discussion has been closed.