Responsive issues on load on mobile

Responsive issues on load on mobile

UpdateYourList_comUpdateYourList_com Posts: 3Questions: 1Answers: 0

We have a few pages that if they are viewed on a mobile device, the datatables do not initially go to the responsive layout on load. If you rotate the screen the "+" symbols will then appear. We do have style="width:100%" set as an inline style on all of our tables. I have noticed the same behavior while viewing the tables on a desktop browser. On first load, the responsive layout does not trigger, but the minute you decrease the browser width, the buttons will appear.

Here is an example of our tables being used. Visit the following link:

https://qsep-devl.org/trainingcatalog.aspx

Next, click on one of the options (ASC). The table will load below.

If you then shrink your browser down to a tablet/mobile width.

Once you have the new browser width, hit refresh. You will see that the table doesn't go into responsive mode. If you then grab the browser and just adjust the width a bit, the table will reset itself and the "+" symbols will display.

The same test can be performed on a mobile device. You can rotate the device to trigger the responsive layout.

Replies

  • allanallan Posts: 51,220Questions: 1Answers: 7,710 Site admin

    Hi,

    Thanks for your question. I've just tried loading the example page, but unfortunately it doesn't appear to be working at the moment. It just stalls out rather than giving any specific error messages. I'll try again laster.

    First thing I'd check is to make sure that you are using the latest versions of the software?

    Allan

Sign In or Register to comment.