Warning error when upgrading from Editor v1.7.0 to editor v1.9.0

Warning error when upgrading from Editor v1.7.0 to editor v1.9.0

perrotinperrotin Posts: 36Questions: 8Answers: 1

Hello,

I'm trying to upgrade the Editor PHP version of a project I developed years ago.

The editor fires this warning error :

Warning: array_merge(): Argument #2 is not an array Editor-PHP-1.9.0/lib/Editor.php on line 1384

When I'm working on my dev setup, I always display PHP error and the warning kills the editor json page.
I've tried to figure out what was going on, problem seems to be comes from a join in the table definition

->join(
Join::inst( 'x' )
->link( 'y.id_expo','xy.IDExpo' )
->link( 'x.ref_nom', 'xy.IDContact')
->where( 'xy.Role',4 )
->fields(
Field::inst( 'x.prenom', 'prenom')
->set( Field::SET_NONE ),
Field::inst( 'x.nom', 'nom')
->set( Field::SET_NONE )
)
)

It's working fine on Editor 1.7.0. Does the markup changes in newer versions ???

Do you have an idea on what's going wrong there.

Thanks

Answers

  • allanallan Posts: 50,737Questions: 1Answers: 7,581 Site admin

    Hi,

    The code on Editor.php 1384 for version 1.9.0 relates to file upload, but I don't see anything in your above code that uses an upload. Could you post your full PHP code please?

    Also, it would be worth updating to 1.9.1 which fixes a whole lot of issues (not sure what this one is yet, so it may or may not fix it).

    Allan

Sign In or Register to comment.