prevent column metadata

prevent column metadata

bobthecoder64bobthecoder64 Posts: 2Questions: 0Answers: 1

Running into some maxlengths on IIS Server due to other large cookies which I have no control over, other than deleting them, but they'll come back eventually due to other sites on the domain. The datatables header seem to push the request size over the limit. Ive tried using Post rather than Get, but haven't had success with that. Is there no way to just prevent all this column metadata from being part of the query string, or at least reduce its bloat. That's a lot of junk in each request that I don't want on the server (just yet). What I want is a setting like ' TurnOffMetadata:True; or reset the data to just the values I want before sending to the server. what can we do here? Im unclear what all these querystrings are for.

Request URL: http://myserver/mypage.aspx/GetResults?draw=1&columns%5B0%5D%5Bdata%5D=blablaColumnA&columns%5B0%5D%5Bname%5D=&columns%5B0%5D%5Bsearchable%5D=true&columns%5B0%5D%5Borderable%5D=true&columns%5B0%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B0%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B1%5D%5Bdata%5D=blablacolumne&columns%5B1%5D%5Bname%5D=&columns%5B1%5D%5Bsearchable%5D=true&columns%5B1%5D%5Borderable%5D=true&columns%5B1%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B1%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B2%5D%5Bdata%5D=Name&columns%5B2%5D%5Bname%5D=&columns%5B2%5D%5Bsearchable%5D=true&columns%5B2%5D%5Borderable%5D=true&columns%5B2%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B2%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B3%5D%5Bdata%5D=MyOtherColumn&columns%5B3%5D%5Bname%5D=&columns%5B3%5D%5Bsearchable%5D=true&columns%5B3%5D%5Borderable%5D=true&columns%5B3%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B3%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B4%5D%5Bdata%5D=MyId&columns%5B4%5D%5Bname%5D=&columns%5B4%5D%5Bsearchable%5D=true&columns%5B4%5D%5Borderable%5D=true&columns%5B4%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B4%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B5%5D%5Bdata%5D=CompleteColumn&columns%5B5%5D%5Bname%5D=&columns%5B5%5D%5Bsearchable%5D=true&columns%5B5%5D%5Borderable%5D=true&columns%5B5%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B5%5D%5Bsearch%5D%5Bregex%5D=false&columns%5B6%5D%5Bdata%5D=anotherId&columns%5B6%5D%5Bname%5D=&columns%5B6%5D%5Bsearchable%5D=true&columns%5B6%5D%5Borderable%5D=true&columns%5B6%5D%5Bsearch%5D%5Bvalue%5D=&columns%5B6%5D%5Bsearch%5D%5Bregex%5D=false&order%5B0%5D%5Bcolumn%5D=0&order%5B0%5D%5Bdir%5D=asc&start=0&length=10&search%5Bvalue%5D=&search%5Bregex%5D=false&_=1633628351768

Replies

  • kthorngrenkthorngren Posts: 14,135Questions: 25Answers: 3,333
    edited October 7

    Looks like you enabled server side processing (serverSide: true). These are the parameters that are sent as part of server side processing. As you mention you can use POST instead of GET to move the parameters out of the URL. Your server script will need to process the POST data.

    The only way to remove these parameters is to disable server side processing and let ajax retrieve the full dataset.

    Kevin

  • kthorngrenkthorngren Posts: 14,135Questions: 25Answers: 3,333

    I guess you can use the ajax.data option or preXhr event to remove the parameters you don't want to send to the server but that would limit the server scripts ability to sort and search columns, depending on what you remove..

    Kevin

Sign In or Register to comment.