Upload progress bar doesn't works as expected anymore

Upload progress bar doesn't works as expected anymore

perrotinperrotin Posts: 39Questions: 9Answers: 1

Hello,
I've noticed that upload progress bar doesn't works since I've changed Editor version from 1.9.5 to 2.0.10
The progress bar indicates 100% as soon as the upload starts, as a consequence, users don't wait the end of process thinking it's a bug.
I think the issue can be seen on the example page : https://editor.datatables.net/examples/advanced/upload.html

Thank you
Julian

Answers

  • perrotinperrotin Posts: 39Questions: 9Answers: 1

    Hello,

    just a little update on that issue, I've tested with last Editor version 2.1.1 and progress bar is also broken.

    I've also noticed that progress bar was still working on version 2.0.5

  • perrotinperrotin Posts: 39Questions: 9Answers: 1

    I can confirm that this bug appeared on Editor version 2.0.6.

  • allanallan Posts: 60,962Questions: 1Answers: 9,940 Site admin

    Hi - sorry for the delay in getting back to you about this. I clean missed your post before. I'll look into this.

    Allan

  • allanallan Posts: 60,962Questions: 1Answers: 9,940 Site admin

    I've just committed a fix for this to Editor and it will be in 2.1.2. I don't expect that release to be too far away, but if you'd like to modify your local copy, search for the onprogress function:

    xhr.upload.onprogress = function(e) {
    

    In the broken versions there is no e parameter. That needs to be added in.

    Regards,
    Allan

Sign In or Register to comment.