overflow:hidden disables inline editor

overflow:hidden disables inline editor

dpanscikdpanscik Posts: 108Questions: 29Answers: 0

the following disables inline editor for a cell. I would love to both truncate AND have inline editor.

    .truncate100 {
        max-width: 100px;
        white-space: nowrap;
        overflow: hidden;
        text-overflow: ellipsis;

and the Column Defs


                    { "defaultContent": "-", "targets": "_all" },
                    { targets: 1, className: "truncate100" },
                    { targets: 2, className: "truncate100" },
                    { targets: 4, className: "truncate100" },
                    { targets: 5, className: "truncate100" },
                    { targets: 7, className: "truncate100" },

This question has an accepted answers - jump to answer


  • kthorngrenkthorngren Posts: 18,571Questions: 26Answers: 4,406
    Answer ✓

    I'm not sure why that would disable inline editing, it seems to work here in the Position column:

    Can you update the test case or provide a link to your page to show us the issue?

    You could use one line for this:

    { targets: [1,2,3,4,5,7], className: "truncate100" },


  • dpanscikdpanscik Posts: 108Questions: 29Answers: 0

    odd. id redid this and its working now. i must have had a typo somewhere.

Sign In or Register to comment.