Issue with select.blurable with multiple datatables

Issue with select.blurable with multiple datatables

bradmacgregorbradmacgregor Posts: 9Questions: 0Answers: 0

I'm using select 1.2.7 and datatables 1.10.12.

each datatable has the following select options: = {
        style: 'os',
        selector: 'tr:not(.change-from, .decom, .decom-change-from) td:first-child',
        blurable: true

One of the datatables is blurable, but the one which is loaded first becomes not blurable. when I change the order that the tables are loaded, the blurable table switches to the other one, so I don't think it is the individual table configuration.

I've tried manually running on the table, but it is still not blurable. I select a row, then click off, and it doesn't deselect. does this manual command require a redraw or anything? looking through the select code I don't really see any reason for the table to clear the body events, but when I look at the body events, there is only one. Any advice? I do see the documentation specifically uses multiple datatables as a use case for blurable, so I would assume it has been specifically tested.

The debugger appears to only see one datatable?

Information about 1 table available

Data source:    Ajax
Processing mode:    Client-side
Draws:  2
Columns:    29
Rows - total:   35
Rows - after search:    35
Display start:  0
Display length: -1


  • bradmacgregorbradmacgregor Posts: 9Questions: 0Answers: 0

    Turns out this was probably a browser caching issue. ctrl/shift + f5 was not working because it was still showing select 1.2.0. Seems to be working now.

  • allanallan Posts: 54,921Questions: 1Answers: 8,611 Site admin

    Thanks for the update - good to hear you've got it working now.


This discussion has been closed.