Button collection is not shown

Button collection is not shown

Description of problem: After upgrading to the latest version, the Export button configured for the table is not showing any of the buttons.

{
                    extend: 'collection',
                    text: 'Export',
                    buttons: [
                        'copy',
                        'excel',
                        'csv',
                        'pdf',
                        'print'
                    ]
}

In the browser debugger shows no elements

<ul class="dropdown-menu" role="menu"> </ul>

There are no changes done to these buttons. Is something missing? Please let me know.

Thank You
Andreas

This question has accepted answers - jump to:

Answers

  • kthorngrenkthorngren Posts: 17,238Questions: 25Answers: 4,091

    Your code snippet works here:
    http://live.datatables.net/depejiwe/1/edit

    Is something missing?

    Hard to say but check these out:

    1. Make sure you are loading all the Buttons libraries. Use the Download Builder.
    2. Make sure you are using telling Datatables to display the buttons as documented here.

    If this doesn't help then please post a link to your page or a test case replicating the issue so we can help debug.

    Kevin

  • andreas.heckwolf@menturagroup.comandreas.heckwolf@menturagroup.com Posts: 12Questions: 4Answers: 0

    Hello Kevin,

    I downloaded again the library using the Download Builder selecting all options, especially buttons related. Still the dropdown-menu do not show up any elements under Export button. Not sure what else to look at.

    Thanks
    Andreas

  • kthorngrenkthorngren Posts: 17,238Questions: 25Answers: 4,091
    Answer ✓

    We will need to see the problem in order to help. Please update the test case or post a link to a page showing the issue.

    Look for errors in the brows'er console.

    Kevin

  • andreas.heckwolf@menturagroup.comandreas.heckwolf@menturagroup.com Posts: 12Questions: 4Answers: 0

    There is no dropdown menu visible. Earlier it worked! I will see if I can share the link to the site.

  • colincolin Posts: 14,526Questions: 1Answers: 2,482
    Answer ✓

    We're happy to take a look, but as per the forum rules, please link to a test case - a test case that replicates the issue will ensure you'll get a quick and accurate response. Information on how to create a test case (if you aren't able to link to the page you are working on) is available here.

    Cheers,

    Colin

  • andreas.heckwolf@menturagroup.comandreas.heckwolf@menturagroup.com Posts: 12Questions: 4Answers: 0

    Hello,

    The issue was the latest datatables lib was not getting loaded, rather previous version was loaded. After the clean up, it works now.

    Thank You
    Andreas

Sign In or Register to comment.